import re
regex = re.compile(r"(netstat\s*\/(a|n|o|b){1,4})|(netstat\s+-(a|n|o|b){1,4})", flags=re.MULTILINE)
test_str = ("netstat -anob\n"
"netstat -ano\n"
"netstat -anob\n"
"netstat -ano\n"
"netstat /anob\n"
"netstat /ano\n"
"netstat /anob\n"
"netstat /ano\n"
"netstat/anob\n"
"netstat/ano\n"
" netstat /anob\n"
" netstat /ano\n"
"netstat -a\n"
"netstat -an\n"
"netstat /a\n"
"netstat /an\n"
"netstat /ona\n"
"netstat /bona\n"
"netstat /nob\n"
"netstat /noba\n"
"netstat /onab\n"
"netstat /noba\n"
"netstat /abon\n"
"netstat /abn\n"
"netstat /anb\n\n\n\n"
"netstat-anob\n"
"netstat-ano\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")