import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\{(\\s*[A-Fa-f0-9]{0,2}\\s*,)+)\\s*[A-Fa-f0-9]{0,2}\\s*\\})";
final String string = "{01,ff,2,35, C, E, A , F}\n"
+ "\\s*(\\{|,)+\\s*([A-Fa-f0-9]{0,2})\\s*(,|\\})+\\s*";
final String subst = "$1 $2 $3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}