import Foundation
let pattern = #"((\{(\s*[A-Fa-f0-9]{0,2}\s*,)+)\s*[A-Fa-f0-9]{0,2}\s*\})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{01,ff,2,35, C, E, A , F}
\s*(\{|,)+\s*([A-Fa-f0-9]{0,2})\s*(,|\})+\s*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2 $3"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}