re = /((\{(\s*[A-Fa-f0-9]{0,2}\s*,)+)\s*[A-Fa-f0-9]{0,2}\s*\})/
str = '{01,ff,2,35, C, E, A , F}
\\s*(\\{|,)+\\s*([A-Fa-f0-9]{0,2})\\s*(,|\\})+\\s*'
subst = '$1 $2 $3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result