// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((\{(\s*[A-Fa-f0-9]{0,2}\s*,)+)\s*[A-Fa-f0-9]{0,2}\s*\})").unwrap();
let string = "{01,ff,2,35, C, E, A , F}
\\s*(\\{|,)+\\s*([A-Fa-f0-9]{0,2})\\s*(,|\\})+\\s*";
let substitution = "$1 $2 $3";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}