using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)\.(\w+)?";
string substitution = @"\1[\2]";
string input = @"a[a]=20&a[]=21
a.a=20&a.=21
a[77]=20&a[]=21
a.77=20&a.=21
a[]=19&a[77]=20&a[]=21
a.=19&a.77=20&a.=21
a[b][]=1&a[b][]=2&a[b]=3&a[b][]=4
a.b.=1&a.b.=2&a.b=3&a.b.=4
a[][]=20&a[][]=21
a..=20&a..=21
a[]=10&a[][]=20&a[][]=21
a.=10&a..=20&a..=21";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}