import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+)\\.(\\w+)?";
final String string = "a[a]=20&a[]=21\n"
+ "a.a=20&a.=21\n\n"
+ "a[77]=20&a[]=21\n"
+ "a.77=20&a.=21\n\n"
+ "a[]=19&a[77]=20&a[]=21\n"
+ "a.=19&a.77=20&a.=21\n\n"
+ "a[b][]=1&a[b][]=2&a[b]=3&a[b][]=4\n"
+ "a.b.=1&a.b.=2&a.b=3&a.b.=4\n\n"
+ "a[][]=20&a[][]=21\n"
+ "a..=20&a..=21\n\n"
+ "a[]=10&a[][]=20&a[][]=21\n"
+ "a.=10&a..=20&a..=21";
final String subst = "\\1[\\2]";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}