const regex = /(\w+)\.(\w+)?/ugmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+)\\.(\\w+)?', 'ugmi')
const str = `a[a]=20&a[]=21
a.a=20&a.=21
a[77]=20&a[]=21
a.77=20&a.=21
a[]=19&a[77]=20&a[]=21
a.=19&a.77=20&a.=21
a[b][]=1&a[b][]=2&a[b]=3&a[b][]=4
a.b.=1&a.b.=2&a.b=3&a.b.=4
a[][]=20&a[][]=21
a..=20&a..=21
a[]=10&a[][]=20&a[][]=21
a.=10&a..=20&a..=21`;
const subst = `\1[\2]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);