// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?umix)(\w+)\.(\w+)?").unwrap();
let string = "a[a]=20&a[]=21
a.a=20&a.=21
a[77]=20&a[]=21
a.77=20&a.=21
a[]=19&a[77]=20&a[]=21
a.=19&a.77=20&a.=21
a[b][]=1&a[b][]=2&a[b]=3&a[b][]=4
a.b.=1&a.b.=2&a.b=3&a.b.=4
a[][]=20&a[][]=21
a..=20&a..=21
a[]=10&a[][]=20&a[][]=21
a.=10&a..=20&a..=21";
let substitution = "\\1[\\2]";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}