using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([a-z_]+):((\d+M)|all):{0,}([a-z_]+){0,}";
string input = @"ualan:10M:strel";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}