package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z_]+):((\d+M)|all):{0,}([a-z_]+){0,}`)
var str = `ualan:10M:strel`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}