$re = '/([a-z_]+):((\d+M)|all):{0,}([a-z_]+){0,}/';
$str = 'ualan:10M:strel';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);