const regex = /([a-z_]+):((\d+M)|all):{0,}([a-z_]+){0,}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z_]+):((\\d+M)|all):{0,}([a-z_]+){0,}', '')
const str = `ualan:10M:strel`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}