using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^document\/([a-z0-9-]+)?\/?([a-z0-9-\W\s]+?)?\/?$";
string input = @"document/edit/STAT%2F12/
";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}