re = /^document\/([a-z0-9-]+)?\/?([a-z0-9-\W\s]+?)?\/?$/i
str = 'document/edit/STAT%2F12/
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end