$re = '/^document\/([a-z0-9-]+)?\/?([a-z0-9-\W\s]+?)?\/?$/i';
$str = 'document/edit/STAT%2F12/
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);