const regex = /^document\/([a-z0-9-]+)?\/?([a-z0-9-\W\s]+?)?\/?$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^document\\\/([a-z0-9-]+)?\\\/?([a-z0-9-\\W\\s]+?)?\\\/?$', 'i')
const str = `document/edit/STAT%2F12/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}