using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\w+)|(""(.*?)"")";
string substitution = @"+$1$2";
string input = @"this is a ""text field"" need ""to replace""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}