package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\b\w+)|("(.*?)")`)
var str = `this is a "text field" need "to replace"`
var substitution = "+$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}