$re = '/(\b\w+)|("(.*?)")/';
$str = 'this is a "text field" need "to replace"';
$subst = "+$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;