import Foundation
let pattern = #"(\b\w+)|("(.*?)")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"this is a "text field" need "to replace""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"+$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)