using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"%[A-Z][A-Z0-9_]{1,99}%";
string input = @"Wowie, there's %ONLINE_PLAYERS% people playing! That's crazy!
I probably used the wrong %PLACEHOLDER%, but oh well. %MEOW%";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}