package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)%[A-Z][A-Z0-9_]{1,99}%`)
var str = `Wowie, there's %ONLINE_PLAYERS% people playing! That's crazy!
I probably used the wrong %PLACEHOLDER%, but oh well. %MEOW%`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}