// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)%[A-Z][A-Z0-9_]{1,99}%").unwrap();
let string = "Wowie, there's %ONLINE_PLAYERS% people playing! That's crazy!
I probably used the wrong %PLACEHOLDER%, but oh well. %MEOW%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}