$re = '/%[A-Z][A-Z0-9_]{1,99}%/m';
$str = 'Wowie, there\'s %ONLINE_PLAYERS% people playing! That\'s crazy!
I probably used the wrong %PLACEHOLDER%, but oh well. %MEOW%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);