package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\((?:[^)(]|(?R))*\)`)
var str = `(2*x^2 + 5*x - (2*x - 3)^(1/2))/(1 + x)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}