package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(:([^:]*:){2})$`)
var str = `:asdf:ghkl:zxcv:`
var substitution = ":"
fmt.Println(re.ReplaceAllString(str, substitution))
}