import Foundation
let pattern = #"(:([^:]*:){2})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #":asdf:ghkl:zxcv:"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #":"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)