$re = '/(:([^:]*:){2})$/';
$str = ':asdf:ghkl:zxcv:';
$subst = ":";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;