using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bcat=(?:\d+,)*(8(?!\d),?)";
string input = @"?view=list&cat=3,1,8,18&sort=asc
?view=list&cat=8,18&sort=asc
?view=list&cat=8&sort=asc
?view=list&cat=3,1,8,18,8&sort=asc
?view=list&cat=3,1,8&sort=asc";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}