const regex = /\bcat=(?:\d+,)*(8(?!\d),?)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bcat=(?:\\d+,)*(8(?!\\d),?)', 'g')
const str = `?view=list&cat=3,1,8,18&sort=asc
?view=list&cat=8,18&sort=asc
?view=list&cat=8&sort=asc
?view=list&cat=3,1,8,18,8&sort=asc
?view=list&cat=3,1,8&sort=asc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}