$re = '/\bcat=(?:\d+,)*(8(?!\d),?)/';
$str = '?view=list&cat=3,1,8,18&sort=asc
?view=list&cat=8,18&sort=asc
?view=list&cat=8&sort=asc
?view=list&cat=3,1,8,18,8&sort=asc
?view=list&cat=3,1,8&sort=asc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);