import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bcat=(?:\\d+,)*(8(?!\\d),?)";
final String string = "?view=list&cat=3,1,8,18&sort=asc\n"
+ "?view=list&cat=8,18&sort=asc\n"
+ "?view=list&cat=8&sort=asc\n"
+ "?view=list&cat=3,1,8,18,8&sort=asc\n"
+ "?view=list&cat=3,1,8&sort=asc";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}