using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\{?(?<key>.*?):(?<val>[""].*[""]?|.*?)[,\W]\}?";
string input = @"{1:aa,2:bb,3:""aa:bb""}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}