re = /\{?(?<key>.*?):(?<val>["].*["]?|.*?)[,\W]\}?/
str = '{1:aa,2:bb,3:"aa:bb"}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end