package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{?(?<key>.*?):(?<val>["].*["]?|.*?)[,\W]\}?`)
var str = `{1:aa,2:bb,3:"aa:bb"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}