#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(http[s]?:\/\/)?([^/\s]+\/)(.*)"
Local $sString = "https://www.mysite.com/en/myslug/" & @CRLF & _
"" & @CRLF & _
"https://www.subdomain.mysite.com/en/myslug/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")