package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http[s]?:\/\/)?([^/\s]+\/)(.*)`)
var str = `https://www.mysite.com/en/myslug/
https://www.subdomain.mysite.com/en/myslug/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}