import Foundation
let pattern = #"(http[s]?:\/\/)?([^/\s]+\/)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.mysite.com/en/myslug/
https://www.subdomain.mysite.com/en/myslug/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}