using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http[s]?:\/\/)?([^/\s]+\/)(.*)";
string input = @"https://www.mysite.com/en/myslug/
https://www.subdomain.mysite.com/en/myslug/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}