package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<iframe(?: [^>]*?)?(?:\/>|>.*?<\/iframe>)`)
var str = `<iframe/>
<iframe />
<iframe></iframe>
<iframe src="something">more things</iframe>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}