// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)<iframe(?: [^>]*?)?(?:\/>|>.*?<\/iframe>)").unwrap();
let string = "<iframe/>
<iframe />
<iframe></iframe>
<iframe src=\"something\">more things</iframe>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}