$re = '/<iframe(?: [^>]*?)?(?:\/>|>.*?<\/iframe>)/mi';
$str = '<iframe/>
<iframe />
<iframe></iframe>
<iframe src="something">more things</iframe>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);