re = /<iframe(?: [^>]*?)?(?:\/>|>.*?<\/iframe>)/mi
str = '<iframe/>
<iframe />
<iframe></iframe>
<iframe src="something">more things</iframe>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end