using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ACRF_([^_]*)_[^_]*";
string input = @"ACRF_8d7925ad-d0c7-43ee-8499-3e897029d519_0020-09-30-18-27-00.acrf";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}