re = /ACRF_([^_]*)_[^_]*/i
str = 'ACRF_8d7925ad-d0c7-43ee-8499-3e897029d519_0020-09-30-18-27-00.acrf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end