package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)ACRF_([^_]*)_[^_]*`)
var str = `ACRF_8d7925ad-d0c7-43ee-8499-3e897029d519_0020-09-30-18-27-00.acrf`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}