// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)ACRF_([^_]*)_[^_]*").unwrap();
let string = "ACRF_8d7925ad-d0c7-43ee-8499-3e897029d519_0020-09-30-18-27-00.acrf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}