const regex = /(COT|MED)[AB]?-?[\dJK]{1,8}(\s+D{1,3})?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(COT|MED)[AB]?-?[\\dJK]{1,8}(\\s+D{1,3})?\\b', 'gm')
const str = `MED-125
COTA-1224
MED4
COTB-892K777
MED-33 DDD
MED-12J44445
MED-234J5672
COT-11161K11111111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}