use strict;
my $str = 'MED-125
COTA-1224
MED4
COTB-892K777
MED-33 DDD
MED-12J44445
MED-234J5672
COT-11161K11111111111111';
my $regex = qr/(COT|MED)[AB]?-?[\dJK]{1,8}(\s+D{1,3})?\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}